Description
定义一个包含图书信息(书号、书名、价格)的链表,读入相应的图书数据来完成图书信息表的创建,然后将读入的图书逆序存储,逐行输出逆序存储后每本图书的信息。
Input
输入n+1行,第一行是图书数目n,后n行是n本图书的信息(书号、书名、价格),每本图书信息占一行,书号、书名、价格用空格分隔,价格之后没有空格。其中书号和书名为字符串类型,价格为浮点数类型。
Output
总计n行,第i行是原有图书表中第n-i+1行的图书的信息(书号、书名、价格),每本图书信息占一行,书号、书名、价格用空格分隔。其中价格输出保留两位小数。
Sample Input
8
9787302257646 Data-Structure 35.00
9787302164340 Operating-System 50.00
9787302219972 Software-Engineer 32.00
9787302203513 Database-Principles 36.00
9787810827430 Discrete-Mathematics 36.00
9787302257800 Data-Structure 62.00
9787811234923 Compiler-Principles 62.00
9787822234110 The-C-Programming-Language 38.00
Sample Output
9787822234110 The-C-Programming-Language 38.00
9787811234923 Compiler-Principles 62.00
9787302257800 Data-Structure 62.00
9787810827430 Discrete-Mathematics 36.00
9787302203513 Database-Principles 36.00
9787302219972 Software-Engineer 32.00
9787302164340 Operating-System 50.00
9787302257646 Data-Structure 35.00
参考程序
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#define LEN 100
#define ROOM sizeof(struct BookInfo)
struct BookInfo
{
char Number[LEN];
char Name[LEN];
float Price;
struct BookInfo *next;
};
struct BookInfo* CreatList(int n)
{
//头插法创建链表
int i;
struct BookInfo *head,*p1;
head=(struct BookInfo*)malloc(ROOM);
head->next=NULL;
for(i=0;i<n;i++)
{
p1=(struct BookInfo*)malloc(ROOM);
scanf("%s%s%f",p1->Number,p1->Name,&p1->Price);
p1->next=head->next;
head->next=p1;
}
return head;
}
int main()
{
int n;
struct BookInfo *List,*p1;
scanf("%d",&n);
List=CreatList(n);
p1=List->next;
while(p1)
{
//遍历链表
printf("%s %s %.2f\n",p1->Number,p1->Name,p1->Price);
p1=p1->next;
}
return 0;
}
/*
8
9787302257646 Data-Structure 35.00
9787302164340 Operating-System 50.00
9787302219972 Software-Engineer 32.00
9787302203513 Database-Principles 36.00
9787810827430 Discrete-Mathematics 36.00
9787302257800 Data-Structure 62.00
9787811234923 Compiler-Principles 62.00
9787822234110 The-C-Programming-Language 38.00
*/
好久没写单链表的题了,今天复习一下 *
版权声明:本文不是「本站」原创文章,版权归原作者所有 | 原文地址: